Приложения для iOS 2.x в App Store больше допущены не будут

|
FavoriteLoading В закладки
Приложения для iOS 2.x в App Store больше допущены не будут

До релиза iOS 4 Apple особо не обращала внимания на версию мобильной ОС, на которую ориентированы те или иные приложения в App Store, будь то iOS 2.х или же iOS 3.x. С выходом iOS 4.0 компания решила изменить устоявшуюся практику. В блоге разработчиков Apple сообщила, что программы, ориентированные на iOS 2.x, больше не поддерживаются.

Более того, разработчикам необходимо в ближайшее время переработать старые программы под iOS 3.x или более новую ОС, иначе они будут удалены из магазина приложений. Также Apple рекомендует адаптировать приложения сразу под iOS 4, в которой появилось много новых возможностей. Это сделает продукты более привлекательными для потребителей.

iOS 4 совершенно бесплатно доступна для iPhone 3G, 3GS, iPod touch второго и третьего поколений. iPhone 4 изначально поставляется с такой операционной системой. Самые первые гаджеты Apple на базе iOS (iPhone 2G и iPod touch 1G) не поддерживаются, а все особенности iOS 4 в полной мере реализованы лишь в телефонах двух последних поколений и iPod touch 3G. [9 to 5 Mac]

Поставьте оценку:

1 Звезд2 Звезды3 Звезды4 Звезды5 Звезд (Нет голосов)
Оставайся в теме. Подпишись на наш Telegram 👏
... и не забывай читать наш Facebook и Twitter 🍒
FavoriteLoading В закладки
undefined
iPhones.ru
До релиза iOS 4 Apple особо не обращала внимания на версию мобильной ОС, на которую ориентированы те или иные приложения в App Store, будь то iOS 2.х или же iOS 3.x. С выходом iOS 4.0 компания решила изменить устоявшуюся практику. В блоге разработчиков Apple сообщила, что программы, ориентированные на iOS 2.x, больше не поддерживаются. Более...
Прокомментировать

🙈 Комментарии 15

  1. iKatraN avatar
    iKatraN30 июня 2010
    0

    Ну и нормально, 2.х это уже анахронизм

  2. )I(yk avatar
    )I(yk30 июня 2010
    0

    2.х это не анахронизм,это классика :)

  3. R2 Soft avatar
    R2 Soft30 июня 2010
    0

    Для этого достаточно просто собрать приложение под последней SDK? Или еще надо что-то сделать?

  4. MYST2002 avatar
    MYST200230 июня 2010
    0

    старье сливать. прогресс неумолим

  5. FataLL avatar
    FataLL30 июня 2010
    0

    Не хотелось бы начинать очередной холивар, но вот тут и проходит тонкая грань между пресловутой “надёжностью” эппл. Более новый продукт остаётся, а его предшественник просто и тупо “не поддерживается”, хотя далеко не все возможности исчерпаны и все функции отточены. Если бы майкрософт не поддерживала бы всё подряд, начиная с древнющего доса, то и в винде проблем было бы гораздо меньше… Кстати, в основном появляются эти косяки у не совсем грамотных пользователей, которые валят в кучу и кислое, и пресное, благо возможность есть… А ведь не исключено, что старенький 2г вполне мог бы тянуть все функции “четвёрки”, если код как следует вылизать и оптимизировать. Шутка ли, скоро у всех в кармане будет запросто сидеть почти полноценная десктоп-система по параметрам, занимающаяся достаточно примитивными задачами…

  6. )I(yk avatar
    )I(yk30 июня 2010
    0

    На самом деле я не удивлюсь,если годика через 3 первый айфон вообще перестанет звонить.

  7. withhead avatar
    withhead30 июня 2010
    0

    А я люблю свой 2G. Любил, люблю и буду любить ) И мне на надо другого G…

  8. vitalik2k avatar
    vitalik2k30 июня 2010
    0

    может кто знает, на Apple Developer можно скачть только iPhone SDK 4.0 , 3.1.3 они убрали. Если собрать приложение в xCode, то там 2 варианта – 3.2 (iPad) и 4.0. Значит ли это что на телефонах с 3.1.3 оно не будет работать?

  9. robert_zakiev avatar
    robert_zakiev30 июня 2010
    0

    да виталик ты прав)

  10. bronenos avatar
    bronenos30 июня 2010
    0

    vitalik, я скачал предыдущий с торрента.
    и поставил в итоге два хкода – для 3.0 и 4.0

    3.0 на ближайшее время, 4.0 – на будушее
    ибо я не могу перескочить на 4.0 сразу, поскольку не смог пока настроить, чтоб компилилось на 4.0, но работало и на 3.0

    верю, что можно
    гуглить надо, разговоры там ведутся про это

  11. vitalik2k avatar
    vitalik2k30 июня 2010
    0

    bronenos, это хак – качать с торрента, если идти официальным путём, то надо качать с developer.apple.com и компилить тем что есть, если это политика аппл (принудить всех перейти на 4.0), то да будет так, просто нужно на кого-то ссылаться будет почему у клиента 3.1.3 и не работает новая версия программы, скомпиленная под 4.0

  12. vitalik2k avatar
    vitalik2k30 июня 2010
    0

    И мне такая политика нравится – не разводить зоопарк версий как с айндройдом (1.6, 2.1, 2.2 + 6 размеров экранов), на разработчика меньше нагрузка.

  13. Hizgil avatar
    Hizgil30 июня 2010
    0

    ну и правильно пора уже

  14. ipsi avatar
    ipsi30 июня 2010
    0

    Это не кризис, это …

    Для меня, как для разработчика, это просто ужасно. Мы планировали поддержку всех девайсов на неограниченное время, теперь этого не будет. Фактически, люди купившие мою программу будут обязаны купить новое устройство, чтобы скачать апдейт моей программы.

    + Если еще учитывать что на хаке у меня только SDK 2.2.1 и как теперь залить в AppStore полностью готовый апдейт – загадка…

  15. Igor10k avatar
    Igor10k1 июля 2010
    0

    правильно делают ) apple как толкала прогресс, так и толкает) не знаю про какую “надежность” apple говорили сверху, они вроде всегда творили че хотели и ничего не обещали ) сбросить с поддержки 3-годичной давности девайсы это вполне нормально я считаю) не слышал я что-то чтоб нокия или любая другая компания так долго поддерживала свое мобильное барахло )

Вы должны авторизоваться или зарегистрироваться для комментирования.

Нашли орфографическую ошибку в новости?

Выделите ее мышью и нажмите Ctrl+Enter.

Как установить аватар в комментариях?

Ответ вот здесь