Разработчики просят не устанавливать iOS 16. Жест тремя пальцами теперь мешает в играх и программах

Артём Баусов avatar | 6
FavoriteLoading В закладки
Разработчики просят не устанавливать iOS 16. Жест тремя пальцами теперь мешает в играх и программах

Некоторые разработчики начали предупреждать пользователей о том, что при работе с iOS 16 возникает неприятный баг.

Речь идет про жесты касания тремя пальцами для вызова панели редактирования текста и свайпа тремя пальцами влево/вправо для отмены/повтора действия. Они срабатывают в играх и приложениях, которые для этого не предназначены.

Проблемы наблюдаются в программах, которые требуют использования сразу нескольких пальцев, например, в музыкальных играх или приложениях, вроде GarageBand. Вместо ожидаемого действия юзер активирует ту самую панель или отмену последнего жеста.

Подобная ошибка возникала ещё во времена iOS 13, когда добавили новые жесты. Однако тогда Apple оперативно всё исправила, а сейчас, по всей видимости, снова сломала.

Вы можете легко это проверить даже в штатных приложениях. Например, сведите 3 пальца в Камере — появится сообщение «Нечего копировать», хотя так быть не должно.

В iOS 16.1 beta 1 проблема сохраняется. Ждем исправление. [9to5]

1 Звезд2 Звезды3 Звезды4 Звезды5 Звезд (18 голосов, общий рейтинг: 4.61 из 5)
🤓 Хочешь больше? Подпишись на наш Telegram.
FavoriteLoading В закладки
undefined
iPhones.ru
В новой бете ошибка тоже присутствует.
Прокомментировать

🙈 Комментарии 6

  1. alexmaru avatar
    alexmaru15 сентября в 14:06
    2

    ну, на айпаде это сломало GarageBand ещё при iPad 2, и что-то никто это не фиксил.

  2. Mark_F avatar
    Mark_F15 сентября в 15:02
    1

    Задолбал баг, когда редактируешь фотографию в разметке и хочешь приблизить фото, жест разводки двумя пальцами он воспринимает как нечто пишущее и оставляет полосы, у кого-нибудь было подобное?

    Brakeless avatar
    Brakeless15 сентября в 16:49
    1

    @Mark_F, Уже года два кайфую от этого на iPhone XS))

  3. Максим avatar
    Максим15 сентября в 17:25
    1

    Для себя решил, что если и обновляться – то не раньше iOS 16.4 15.4 и так далее.

    Владислав Горящий avatar
    Владислав Горящий16 сентября в 10:37
    0

    @Максим, в этом есть логика. как разработчик я прекрасно понимаю, что первые глобальные обновления всегда несут в себе риски разных багов, которые фиксятся уже в минорных версиях

  4. Player A avatar
    Player A16 сентября в 9:28
    1

    I dont give a fuck; I am not going to install ios 16 earlier than spring 23

Вы должны авторизоваться или зарегистрироваться для комментирования.

Нашли орфографическую ошибку в новости?

Выделите ее мышью и нажмите Ctrl+Enter.

Как установить аватар в комментариях?

Ответ вот здесь