Найдены лучшие кроссовки на лето

Новые версии macOS не будут нормально работать с 32-битными приложениями, но есть решение

|
FavoriteLoading В закладки
Новые версии macOS не будут нормально работать с 32-битными приложениями, но есть решение

Apple уже начала предупреждать пользователей, что их 32-битные приложения не будут нормально работать с новыми версиями macOS. Такие приложения исчезнут из App Store и не будут туда допускаться. Не стоит переживать на этот счёт.

В MacWorld полагают, что вы всё же сможете продолжить пользоваться такими приложениями. И это, кажется, действительно так.

Суть в том, что если вы хотите полноценно использовать такие программы без каких-либо ошибок, никто не мешает вам запустить виртуальную машину под управлением более ранней версии macOS. Для этого нужна лишь VMWare Fusion, либо Parallels Desktop.

Эти программы умеют запускать:

• Mac OS X 10.7 Mavericks
• Mac OS X 10.8 Yosemite
• Mac OS X 10.9 El Capitan
• Mac OS X 10.10 Sierra
• macOS 10.11 High Sierra

Следовательно, подняв такую виртуальную машину, вы сможете и дальше спокойно пользоваться 32-битными программами. [9to5]

FavoriteLoading В закладки
undefined
iPhones.ru
Причём абсолютно легально.
Прокомментировать

🙈 Комментарии 15

  1. Kaji avatar
    Kaji16 мая в 17:14
    6

    Ой костыыыыль…

  2. iWanderer avatar
    iWanderer16 мая в 17:14
    2

    @Артём Баусов, вроде, Вы и писали: ОБ ЭТОМ МАКе -> ОТЧЁТ О СИСТЕМЕ -> ПО (в левом столбце -> ПРОГРАММЫ (в разделе ПО) и в правом окне в крайнем правом столбике указано, 64-битная архитектура каждой программы или нет.

    У меня Ель Капитан стоит – и то почти все программы (за редким исключением, М.-О. в частности, 32-битные). Так что особо волноваться, полагаю, нужды нет.

  3. Pavel Volobuev avatar
    Pavel Volobuev16 мая в 17:18
    0

    Я даже не знаю, какую древнюю программу нужно юзать, чтобы она была незаменима и 32-х битна

    firesnake avatar
    firesnake16 мая в 21:27
    0

    @Pavel Volobuev, например Steam.

    Pavel Volobuev avatar
    Pavel Volobuev16 мая в 21:31
    0

    @firesnake, ну Мак плохо с играми дружит, так что не вариант

    firesnake avatar
    firesnake16 мая в 21:49
    4

    @Pavel Volobuev, нормально он дружит и игр в Стиме полно.

  4. Jojoker avatar
    Jojoker16 мая в 17:21
    5

    Как “спокойно” у вас равняется “в виртуалке”?
    Вообще Мак ОС славится своим актуальным софтом, нет того legacy-наследия как у винды (которое отлично идет под вайном в той же Мак ОС). Поэтому если программа нужная то ее обновят или будет альтернатива. Вот я долго бомбил что в последних двух Мак ОС не работает Icon Composer, а потом нашел Iconie которая лучше в сто раз. Поэтому не надо держатся на старое.
    А если у кого стоит Мак для работы в студии и все настроено, то можно просто не обновлять его.

  5. Alex88 avatar
    Alex8816 мая в 17:23
    2

    И зачем эти виртуалки если можно установить две системы, допустим 10.12.6.

  6. Menzoberonzan avatar
    Menzoberonzan16 мая в 17:36
    7

    О том, что и VMware и Parallels стоят денег ребята упомянуть забыли:)

    loudless avatar
    loudless16 мая в 22:44
    2

    @Menzoberonzan, Parallels стоит своих денег

    SirKliv avatar
    SirKliv17 мая в 16:22
    0

    @Menzoberonzan, VirtualBox совершенно бесплатен.

  7. Alexid avatar
    Alexid16 мая в 17:51
    9

    Артем, Вы вводите в заблуждение читателей. Почитайте внимательно заявления Apple на английском языке на их сайте для разработчиков.

    Apple предупредила, что в следующей версии macOS не будет *полноценной* поддержки 32-bit приложений. Т.е. такие приложения исчезнут из AppStore и не будут туда допускаться. Это точно подтверждено.

    Но пока речи не идет о полном запрете выполнения 32-bit приложений (скачанных вне AppStore). Предупреждение при запуске будет показываться, но приложение БУДЕТ работать.

    Цитата: “macOS High Sierra would be the last version of macOS to run 32-bit apps without compromise.”
    support.apple.com/en-gb/HT208436
    Т.е. 32-бит будет работать но неполноценно (например предупреждение при запуске, не пускают в AppStore).

    еще оттуда: “The 64-bit transition for macOS and macOS apps is still underway, so final transition dates have not yet been established.”

    Точная дата прекращения поддержки 32-bit еще НЕ определена.

    crosslink avatar
    crosslink16 мая в 18:05
    2

    @Alexid, И о чем тогда писать новость? А так можно придумать врага и бороться.

  8. Heller avatar
    Heller16 мая в 18:04
    0

    лол, ну пиздец))

  9. scroudge avatar
    scroudge16 мая в 18:32
    0

    Прошу простить, если не прав. Но Уважаемая компания Эппл пошла по пути Другой уважаемой компании и подумала только о себе.

    Я свитчер. Есть и маки и винда и хакинтош и линукы.

    Обидно – и это “скурвились”

Вы должны авторизоваться или зарегистрироваться для комментирования.

Нашли орфографическую ошибку в новости?

Выделите ее мышью и нажмите Ctrl+Enter.

Как установить аватар в комментариях?

Ответ вот здесь